Jump to content

- - - - -

New ioCow release



136 replies to this topic

#21 Lee

Lee

    Safety not guaranteed.

  • Members
  • 1,418 posts

Posted 29 December 2008 - 09:09 PM

So, any idea why I can't connect to any servers?
3.141592653589793238462643383279502884197169399375105820974944592307816406286208998628034825342117067982
14808651328230664709384460955058223172535940812848111745028410270193852110555964462294895493038196442881
09756659334461fnord28475648233786783165271201909145648566923460348610454326648213393607260249141273724587
006606315588174881520920962829254091715364367892590360011330530548820466521384146951941511609

#22 John

John

    Computer Techie

  • RPG-X Tester
  • 285 posts

Posted 29 December 2008 - 09:11 PM

I've got rid of the lag on mine now but when I try connecting to a server I get kicked out of RPG-X onto the holomatch main menu

#23 Grizz

Grizz

    Member

  • RPG-X Tester
  • 984 posts

Posted 29 December 2008 - 10:10 PM

As do I - *cry*

#24 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 29 December 2008 - 10:19 PM

Plz scroll up in the console and report the error message here.

#25 John

John

    Computer Techie

  • RPG-X Tester
  • 285 posts

Posted 29 December 2008 - 10:25 PM

I've got it connecting now, it does not like it if your rpg folder is not named rpg-x2 exactly.

#26 Lee

Lee

    Safety not guaranteed.

  • Members
  • 1,418 posts

Posted 29 December 2008 - 11:13 PM

----------------------
110606 files in pk3 files
RE_Shutdown( 0 )
Hunk_Clear: reset the hunk ok
----- R_Init -----

GL_VENDOR: ATI Technologies Inc.
GL_RENDERER: Radeon X1900 GT
GL_VERSION: 2.1.8201 Release
GL_EXTENSIONS: GL_AMD_performance_monitor GL_ARB_depth_texture
GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader
GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_multisample
GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object
GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects
GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow
GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression
GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine
GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float
GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two
GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object
GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos
GL_ATI_draw_buffers GL_ATI_envmap_bumpmap GL_ATI_fragment_shader
GL_ATI_meminfo GL_ATI_separate_stencil GL_ATI_texture_compression_3dc
GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_abgr GL_EXT_bgra
GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate
GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array
GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord
GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample
GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters
GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels
GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color
GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap
GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3D
GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map
GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine
GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic
GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object
GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_vertex_array
GL_KTX_buffer_region GL_NV_blend_square GL_NV_texgen_reflection
GL_SGIS_generate_mipmap GL_SGIS_textu
GL_MAX_TEXTURE_SIZE: 4096
GL_MAX_TEXTURE_UNITS_ARB: 8

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
MODE: -1, 1680 x 1050 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
texture bits: 32
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
compressed textures: disabled
Forcing glFinish
Initializing Shaders
----- finished R_Init -----
Loading dll file ui.
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll: The specified module could not be found.
"
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll: The specified module could not be found.
"
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll: The specified module could not be found.
"
Sys_LoadDll(ui) failed to load library
Failed to load dll, looking for qvm.
Loading vm file vm/ui.qvm...
VM file ui compiled to 1065082 bytes of code
ui loaded in 2689728 bytes on the hunk
244 arenas parsed
75 bots parsed
5 ranksets detected
8 class sets detected
Loading dll file cgame.
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll: The specified module could not be found.
"
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll: The specified module could not be found.
"
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\cgamex86.dll: The specified module could not be found.
"
Sys_LoadDll(cgame) failed to load library
Failed to load dll, looking for qvm.
Loading vm file vm/cgame.qvm...
VM file cgame compiled to 1245108 bytes of code
cgame loaded in 4830048 bytes on the hunk
********************
ERROR: Client/Server game mismatch: RPG-X v2.2 Beta 1/RPG-X v2.1
********************
forcefully unloading cgame vm
RE_Shutdown( 0 )
Hunk_Clear: reset the hunk ok
----- R_Init -----

GL_VENDOR: ATI Technologies Inc.
GL_RENDERER: Radeon X1900 GT
GL_VERSION: 2.1.8201 Release
GL_EXTENSIONS: GL_AMD_performance_monitor GL_ARB_depth_texture
GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader
GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_multisample
GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object
GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects
GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow
GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression
GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine
GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float
GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two
GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object
GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos
GL_ATI_draw_buffers GL_ATI_envmap_bumpmap GL_ATI_fragment_shader
GL_ATI_meminfo GL_ATI_separate_stencil GL_ATI_texture_compression_3dc
GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_abgr GL_EXT_bgra
GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate
GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array
GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord
GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample
GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters
GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels
GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color
GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap
GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3D
GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map
GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine
GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic
GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object
GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_vertex_array
GL_KTX_buffer_region GL_NV_blend_square GL_NV_texgen_reflection
GL_SGIS_generate_mipmap GL_SGIS_textu
GL_MAX_TEXTURE_SIZE: 4096
GL_MAX_TEXTURE_UNITS_ARB: 8

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
MODE: -1, 1680 x 1050 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
texture bits: 32
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
compressed textures: disabled
Forcing glFinish
Initializing Shaders
----- finished R_Init -----
Loading dll file ui.
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll: The specified module could not be found.
"
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll: The specified module could not be found.
"
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll)...
Sys_LoadDll(C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll) failed:
"Failed loading C:\Program Files\Raven\Star Trek Voyager Elite
Force\RPG-X2\uix86.dll: The specified module could not be found.
"
Sys_LoadDll(ui) failed to load library
Failed to load dll, looking for qvm.
Loading vm file vm/ui.qvm...
VM file ui compiled to 1065082 bytes of code
ui loaded in 2689728 bytes on the hunk
244 arenas parsed
75 bots parsed
5 ranksets detected
8 class sets detected
]/condump shit
Dumped console text to shit.

I'm nut sure what to make out of all of it, but some things look iffy. I took out the beginning part that shows a bunch of directories.
3.141592653589793238462643383279502884197169399375105820974944592307816406286208998628034825342117067982
14808651328230664709384460955058223172535940812848111745028410270193852110555964462294895493038196442881
09756659334461fnord28475648233786783165271201909145648566923460348610454326648213393607260249141273724587
006606315588174881520920962829254091715364367892590360011330530548820466521384146951941511609

#27 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 30 December 2008 - 12:38 AM

********************

ERROR: Client/Server game mismatch: RPG-X v2.2 Beta 1/RPG-X v2.1

********************
The patch is your problem :P. Everything else is normal.

#28 khamseen

khamseen

    Member

  • Members
  • 387 posts

Posted 31 December 2008 - 04:56 AM

Don't have any connection issues or lag problems but I've got the same style problem that ioEF used to have with the Cassini. Missing loads of shaders and textures and console is flooded with NULL Poly Shader messages.

Posted Image


#29 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 31 December 2008 - 05:07 AM

That's a problem with the cassini shader file (ioquake3 is more strict in that regard) I have a fixed pk3 uploaded somewhere.

#30 khamseen

khamseen

    Member

  • Members
  • 387 posts

Posted 31 December 2008 - 05:27 AM

Pretty sure I already have that fix as you gave me a file almost a year ago for the Cassini problem when I installed ioEF. Is it the file that's just a shader file in a pk3?

Posted Image


#31 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 31 December 2008 - 05:51 AM

That file should've done it (it works for everyone else at least).

#32 khamseen

khamseen

    Member

  • Members
  • 387 posts

Posted 31 December 2008 - 10:16 PM

Well I still get the problem :( Not too sure why then.

EDIT
Sorry, got it working, I had a shader file in my scripts folder that was only half completed and I had forgotten about it, when I took it out it worked fine.

Posted Image


#33 Telex Ferra

Telex Ferra

    Member

  • Members
  • 1,104 posts

Posted 31 December 2008 - 11:27 PM

As I recall this problem was fixed in beta3

Maybe check your BaseEF and RPG-X2 folders to see if you still have the second beta?

EDIT: Missed above post, sorry

#34 khamseen

khamseen

    Member

  • Members
  • 387 posts

Posted 01 January 2009 - 12:05 AM

LOL until I read your edit I was like... HUH? :P Thanks anyways ;D

Edit (again)

Now I seem to be having issues with the VoIP. I can hear others just fine and when I press the button I've boud it shows the little meter at the top and the stars blink up as I speak but they can't hear anything I say. I checked my rate and it's fine, even boosted it to see if it helped. I've installed OpenAL and no luck. Any suggestions?

Posted Image


#35 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 01 January 2009 - 01:04 AM

Start ioCow and make a /condump. Then copy the parts after ---- Sound init ----- and paste them here please.

#36 khamseen

khamseen

    Member

  • Members
  • 387 posts

Posted 01 January 2009 - 06:57 AM


------ Initializing Sound ------

Loading "OpenAL32.dll"...

Allocated 96 sources.

OpenAL default capture device is 'Realtek HD Audio Input'

OpenAL capture device opened.

OpenAL info:

  Vendor:     Creative Labs Inc.

  Version:    1.1

  Renderer:   Software

  AL Extensions: EAX EAX2.0 EAX3.0 EAX4.0 EAX5.0 EAX3.0EMULATED

EAX4.0EMULATED AL_EXT_OFFSET AL_EXT_LINEAR_DISTANCE AL_EXT_EXPONENT_DISTANCE

  ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE

ALC_EXT_EFX

  Device:     Generic Software

Available Devices:

Generic Hardware

Generic Software

Sound initialization successful.

--------------------------------

Posted Image


#37 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 01 January 2009 - 02:15 PM

I've got exactly the same output. Does recording in windows sound recorder work?

#38 khamseen

khamseen

    Member

  • Members
  • 387 posts

Posted 01 January 2009 - 11:27 PM

Yes it does, plus I use TeamSpeak on a daily basis and that works with no problems lol.

Posted Image


#39 Telex Ferra

Telex Ferra

    Member

  • Members
  • 1,104 posts

Posted 01 January 2009 - 11:30 PM

Take a rock hammer to your mic

#40 khamseen

khamseen

    Member

  • Members
  • 387 posts

Posted 01 January 2009 - 11:32 PM

The mic works just fine, I think the implementation of a rock hammer may hinder its continued use :P

Posted Image





Reply to this topic



  

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users