Jump to content

- - - - -

Just to Clarify



10 replies to this topic

#1 TiM

TiM

    Administrator

  • UberGames Admin
  • 3,425 posts

Posted 09 April 2007 - 02:05 AM

Hey guys!

I`ve moved from Northern Japan down south to Osaka now where I gotz much better access to teh internet.

Anyway... I was talking to Red a few weeks back, and we found out there was a bit of confusion with what I was doing with this mod.

The mod is targetted for vanilla EF, not ioEF. I`m not sure where this assumption came from where I built it for ioEF alone, but that`s not right. :)

ioEF is awesome, but since it has had some pretty funky revamps to it, particularily in the sound API, it still isn`t perfect for the time being.

As a result, please test the features on vanilla Holomatch as much as you can. If the feature works in normal EF, but doesn`t in ioEF, that`s an issue we`d have to hand over to the ioQ3 gang.

Sorry about the confusion lol.

-TiM

#2 Slayer

Slayer

    Bug Hunter

  • Members
  • 385 posts

Posted 09 April 2007 - 02:15 AM

rofl Well this is fun lol

by vanilla you mean normal ef? If so there are some issues o.O
Im Klingon and a Hanyou Dog Demon...AT THE SAME TIME!
[SIGPIC]Posted Image[/SIGPIC]

#3 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 09 April 2007 - 07:01 AM

I just began to like ioEF lol, and there is some stuff that works only in ioEF and doesn't in vEF (like atlantis, menu textures:eek:).

#4 Dom

Dom

    I touch everything

  • UberGames Admin
  • 921 posts

Posted 09 April 2007 - 09:43 AM

The whole ioEF came from the atlantis being an ioEF map only and the mod not working properly in vannila ef.

#5 Anthony

Anthony

    UberGames Developer

  • UberGames Developer
  • 201 posts

Posted 09 April 2007 - 11:51 AM

Yea, can we please stop flogging the dead horse that is 'V EF'. Just ship the ioEF executable and design the mod for that. Its much more flexible for mappers and the mod actually works on it.

Posted Image


#6 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 09 April 2007 - 12:38 PM

Yeah, I think optimizing everything for ioEF is better because it's licensed under GPL so there won't be any problems if you decide to modify the executable code too. It is also a much more capable engine +it has a linux binary. Furthermore the menu textures and Atlnatis only work in io and who cares about the sound 'bugs' :) (i've noticed them too)?

#7 Kori Barnes

Kori Barnes

    Bug Hunter

  • Members
  • 210 posts

Posted 09 April 2007 - 04:35 PM

Well like everyone said, the RPG-X2 menu will not work in normal EF. And Atlantis needs ioEF to run.
Lieutenant Kori Barnes
Chief of Security USS Poseidon NCC-70176-A


#8 Scooter

Scooter

    The Canon Man

  • UberGames Admin
  • 2,545 posts

Posted 09 April 2007 - 10:11 PM

The menu can be fixed to work in vanilla EF. We should try to get things to work in both engines as much as possible.

#9 Gregory House

Gregory House

    AKA: Gregory House

  • RPG-X Tester
  • 462 posts

Posted 10 April 2007 - 12:40 PM

Agreed,

If we use both formats, we'll be able to have a larger target audience, per se.

I don't know much about programming, but I know that .dll files are incompatible with Mac OS X ... (I use Mac OS X) . . . Phenix told me he's working on this issue ... by switching to qvm files which are compatible with Windows and Mac OS X ...

#10 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 10 April 2007 - 04:06 PM

And because because Linux dedicated servers wont work otherwise!
About the audience...why not just include ioEF in the mod? But testing both engines sounds fine to me.

#11 Gregory House

Gregory House

    AKA: Gregory House

  • RPG-X Tester
  • 462 posts

Posted 11 April 2007 - 02:30 AM

Good idea,

and :| I'm still "waiting" for the beta 2 release ... because my laptop is my main PC now :( ... hey ... I have a 90 minute train ride home ... and lot's of power (battery).

Maybe we could include a patch to make the mod Mac-compatible, as in make a version with QVMs instead of DLLs.




Reply to this topic



  

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users