Jump to content

- - - - -

RPG-X2 Beta 1 -Release



29 replies to this topic

#1 Dom

Dom

    I touch everything

  • UberGames Admin
  • 921 posts

Posted 22 March 2007 - 08:59 PM

Relase Date: 22/03/2007
URL: http://bugs.rpg-x.ne...stanyoldfile.7z (107 Megs)
Space Required Unextracted: 385MB
Install: Extract this to your Elite Force folder, you must run the mod in ioEF (ioEF Thread/Download).

Atlantis Beta 1 Refresh 1: http://www.rpg-x.net...read.php?t=1300

Fixed bugs:
A few thousand over the last year and a half

New Features:
Lots, undocumented (sorry)

Known Bugs:
See the bug tracker

What we need tested:
We need the atlantis map tested (rpg_atlantis)
The model system tested
pritty much everthing tested

I will try and get a test server up later tonight or tomorrow

#2 Kori Barnes

Kori Barnes

    Bug Hunter

  • Members
  • 210 posts

Posted 22 March 2007 - 09:02 PM

Cool! I can't remember, do you need your CD if you run threw ioEF? Cause I want to try it a bit in SPMP before I go on th test server when it is up.
Lieutenant Kori Barnes
Chief of Security USS Poseidon NCC-70176-A


#3 Dom

Dom

    I touch everything

  • UberGames Admin
  • 921 posts

Posted 22 March 2007 - 09:04 PM

Cool! I can't remember, do you need your CD if you run threw ioEF? Cause I want to try it a bit in SPMP before I go on th test server when it is up.


If it does use then create a bat file in your ef directory and place this in it

iostvoyHM-1.37 +set bot_enable 0 +set fs_game RPG-X2


the bot_enabled 0 bit will stop the game requiring the CD (I dont know why, it just does!)

#4 Kori Barnes

Kori Barnes

    Bug Hunter

  • Members
  • 210 posts

Posted 22 March 2007 - 09:06 PM

Ok awesome, I just found my CD anyways.

Wow, I never realized how good 7zip compresses.
Lieutenant Kori Barnes
Chief of Security USS Poseidon NCC-70176-A


#5 Slayer

Slayer

    Bug Hunter

  • Members
  • 385 posts

Posted 23 March 2007 - 04:20 AM

I gotta wait till Friday until then enjoy.
Im Klingon and a Hanyou Dog Demon...AT THE SAME TIME!
[SIGPIC]Posted Image[/SIGPIC]

#6 Gregory House

Gregory House

    AKA: Gregory House

  • RPG-X Tester
  • 462 posts

Posted 23 March 2007 - 03:39 PM

Same with me, even though I have my laptop (Mac) ... it does not properly run ioEF/RPG-X ... so .. I'll load it onto my PC instead and :confused:

#7 Kadratis Velevere

Kadratis Velevere

    Bug Hunter

  • Members
  • PipPipPip
  • 59 posts

Posted 23 March 2007 - 09:03 PM

Looks promising! :confused: I'll fire up EF this weekend and start up ye ol' word processor!

Kadratis Io Velevere | RPG-X Profile
Resume your disorder...


#8 Kori Barnes

Kori Barnes

    Bug Hunter

  • Members
  • 210 posts

Posted 23 March 2007 - 10:12 PM

Kad :confused:
Lieutenant Kori Barnes
Chief of Security USS Poseidon NCC-70176-A


#9 Slayer

Slayer

    Bug Hunter

  • Members
  • 385 posts

Posted 24 March 2007 - 01:55 AM

Did this file take forever to download with anyone else? Im usually done dling in about 3-4 min with a file of this size. Anyone else have issues?
Im Klingon and a Hanyou Dog Demon...AT THE SAME TIME!
[SIGPIC]Posted Image[/SIGPIC]

#10 Kori Barnes

Kori Barnes

    Bug Hunter

  • Members
  • 210 posts

Posted 24 March 2007 - 02:35 AM

Took me 30 secs. Tho it seems to be slow right now.
Lieutenant Kori Barnes
Chief of Security USS Poseidon NCC-70176-A


#11 Gregory House

Gregory House

    AKA: Gregory House

  • RPG-X Tester
  • 462 posts

Posted 24 March 2007 - 06:38 PM

If it does use then create a bat file in your ef directory and place this in it


the bot_enabled 0 bit will stop the game requiring the CD (I dont know why, it just does!)



Hmm ... I am having a weird issue on my (Windows) PC ... It loads just fine (RPG-X) but it won't let me load any maps :(

it says "awaiting connection ... 0" and then it goes back to the main menu... ?

what should I do?

#12 William

William

    Lead Level Developer - RPG-X

  • UberGames Developer
  • 728 posts

Posted 24 March 2007 - 08:05 PM

Any maps?

#13 Kadratis Velevere

Kadratis Velevere

    Bug Hunter

  • Members
  • PipPipPip
  • 59 posts

Posted 24 March 2007 - 08:24 PM

I've got a different problem on my side of the fence. I've got text problems all over the map. I've got ioEF installed, and I've used the BAT file like asked, but nothing has worked. This is a fresh install of EF, by the way.

Screenshot

Kadratis Io Velevere | RPG-X Profile
Resume your disorder...


#14 Kori Barnes

Kori Barnes

    Bug Hunter

  • Members
  • 210 posts

Posted 24 March 2007 - 08:25 PM

is folder named RPG-X2? (no space between the x and the 2) Rick has the same problem on his mac.
Lieutenant Kori Barnes
Chief of Security USS Poseidon NCC-70176-A


#15 Kadratis Velevere

Kadratis Velevere

    Bug Hunter

  • Members
  • PipPipPip
  • 59 posts

Posted 24 March 2007 - 08:31 PM

is folder named RPG-X2? (no space between the x and the 2) Rick has the same problem on his mac.

Yup. :(

Kadratis Io Velevere | RPG-X Profile
Resume your disorder...


#16 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 24 March 2007 - 08:37 PM

I know what the problem is, it is loading the old quake virtual machines (qvms) instead of the new dll's. You can see that because there is no server browser in the main menu.
- Make sure you have the pak92,pk3 in baseEF
- Make sure the dll's are in the correct folder
Hope it works ;)(nice to see you again btw :().

#17 Kori Barnes

Kori Barnes

    Bug Hunter

  • Members
  • 210 posts

Posted 24 March 2007 - 08:42 PM

wait? I need the pk92? I deleted it nd it works fine.. Should I put it back?
Lieutenant Kori Barnes
Chief of Security USS Poseidon NCC-70176-A


#18 Kadratis Velevere

Kadratis Velevere

    Bug Hunter

  • Members
  • PipPipPip
  • 59 posts

Posted 24 March 2007 - 08:45 PM

Hmmm. Just check pak92.pk3, it's in the baseEF folder where it belongs. And the dll files that the beta came with is where it belongs. I'm 100% positive I didn't move anything or install anything else other than the expansion pack and ioEF. This is quite a pickle. :( LOL

Also good to see you again too, Marcin! ;)

Kadratis Io Velevere | RPG-X Profile
Resume your disorder...


#19 Marcin

Marcin

    UberGames Developer

  • UberGames Developer
  • 688 posts

Posted 24 March 2007 - 09:30 PM

The pak92 isn't the problem, I thought it had something special but it loads without it.
It has to be a dll loading problem, I experience the same when running the linux binary of ioEF (because dll's are windows-native):
Posted Image
WIndows emulation with WINE:
Posted Image
So the 3 dynamic link libraries are in RPG-X2 folder then? Does the console say something special(scroll up with page up)? Because mine says:
...
Sys_LoadDll(ui) failed dlopen() completely!
Failed to load dll, looking for qvm.
Loading vm file vm/ui.qvm...
...
Then it loads the 1.1 qvms :(

#20 Kadratis Velevere

Kadratis Velevere

    Bug Hunter

  • Members
  • PipPipPip
  • 59 posts

Posted 24 March 2007 - 10:39 PM

Here's a more detailed analysis.

Here's a directory listing of what is in my STVEF folder.

atnet.inf
binkw32.dll
Ef.isu
efgamex86.dll
efuix86.dll
FFC10.dll
GETINFO.DLL
iostvoyHM-1.37.exe
irunin.bmp
irunin.dat
irunin.lng
OpenALwEAX.exe
RPG-X Beta.bat
stvoy.exe
stvoyHM.exe

Here's a directory listing of what is in my baseEF folder.

expefq3.key
pak0.pk3
pak1.pk3
pak2.pk3
pak3.pk3
pak92.pk3

Here's a directory listing of what is in my RPG-X2 folder.

cgamex86.dll
hmconfig.cfg
qagamex86.dll
rpgx2_beta_pak_0.pk3
uix86.dll

Any other directory listings will be posted upon request. :(

Here's what I can read in the console, since condump won't work. ;)

I'm attempting to run the beta using a .BAT file consisting of the command:

iostvoyHM-1.37 +set bot_enable 0 +set fs_game RPG-X2

But I've also tried going in through ioEF and loading the beta through that to no avail. :( Please note I've done two clean installs now.

Kadratis Io Velevere | RPG-X Profile
Resume your disorder...





Reply to this topic



  

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users